Auto-registration of SandBlast Mobile app on Android 10 devices
with Legacy Management mode does not work
Symptoms
- Automatic registration of SBM app on Android 10 devices with Legacy Management mode does not work.
Cause
- Android 10 changes prevents SBM app from reading device identifiers that make impossible to recognize newly registered device.
Solution
- Long-term solution - SandBlast Mobile recommends to move to Android Enterprise device management of Android 10 devices, as legacy management will be deprecated by Google shortly. Android Enterprise based device management allows to pass parameters to SBM app using AppConfig - this resolves an auto-registration issue for Android 10 devices.
- Mid-term solution - SandBlast Mobile team researches an alternative solution for auto-registration of Android 10 devices with Legacy Management.
- Short-term solution - Manual registration using registration code provided by SMS or email.
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios. |
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