Harmony Mobile: Auto-registration of SandBlast Mobile app on Android 10 devices with Legacy Management mode does not work

Modified on Wed, 12 May, 2021 at 10:33 AM

Auto-registration of SandBlast Mobile app on Android 10 devices 


with Legacy Management mode does not work 

Symptoms
  • Automatic registration of SBM app on Android 10 devices with Legacy Management mode does not work.


Cause
  • Android 10 changes prevents SBM app from reading device identifiers that make impossible to recognize newly registered device.


Solution
  • Long-term solution - SandBlast Mobile recommends to move to Android Enterprise device management of Android 10 devices, as legacy management will be deprecated by Google shortly. Android Enterprise based device management allows to pass parameters to SBM app using AppConfig - this resolves an auto-registration issue for Android 10 devices.

  • Mid-term solution - SandBlast Mobile team researches an alternative solution for auto-registration of Android 10 devices with Legacy Management.

  • Short-term solution - Manual registration using registration code provided by SMS or email.
This solution has been verified for the specific scenario, described by the combination of Product, Version and Symptoms. It may not work in other scenarios.



Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select at least one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article